verticaal zoeken met 2 zoeksleutels

Afgelopen week stelde iemand een vraag over verticaal zoeken. Het ging om het volgende voorbeeld:

vertzoeken-twee-sleutels

In het voorbeeld staan twee tabellen. Excel moet in cel F3 het juiste artikelnummer plaatsen. Het artikelnummer staat in de 2e tabel en is afhankelijk van zowel de code als de lengte. Het juiste artikelnummer in dit voorbeeld is NL2034.

In één van de eerdere artikelen heb ik uitgelegd hoe de VERT.ZOEKEN (Engels: VLOOKUP) functie werkt. We kunnen deze functie ook voor dit voorbeeld gebruiken. Het enige probleem dat we hebben, is dat VERT.ZOEKEN maar met één zoekwaarde kan werken en dat we in het voorbeeld willen zoeken op de combinatie van code en lengte. Meestal los ik dit op door in de zoektabel een extra sleutelkolom op te nemen die de twee zoekwaarden combineert. In dit geval komt het voorbeeld er dan zo uit te zien:

tekst-samenvoegen

De functie die ik gebruik om de sleutelkolom te vullen is TEKST.SAMENVOEGEN (Engels: CONCATENATE). De structuur van deze functie is TEKST.SAMENVOEGEN(tekst1;[tekst2];[tekst3];…). De formule die ik in cel B6 gebruik is TEKST.SAMENVOEGEN(C6;D6). Deze formule kunnen we ook korter opschrijven. Een alternatief voor TEKST.SAMENVOEGEN is het ‘&’ teken. De formule wordt dan =C6&D6.

Als we nu in de VERT.ZOEKEN functie de zoekwaarde op dezelfde manier een combinatie laten zijn van code en lengte, dan kunnen we het artikelnummer aan de hand van de sleutel opzoeken in de 2e tabel. De formule voor cel F3 wordt dan:

=VERT.ZOEKEN(B3&C3;$B$6:$E$9;4;0)

vertzoeken-twee-sleutels-re

VERT.ZOEKEN is één van de functies waarmee je dit voorbeeld kunt oplossen. Echter, we moeten dan wel een extra kolom met een sleutel toevoegen. Het is ook mogelijk om tot een oplossing te komen zonder sleutelkolom. In een van mijn volgende artikelen zal ik dit laten zien.